Keyboard won't work for UK English — Peach OSI\\\\\\\'s Forum


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

This version of our Forum is brand new. We have imported our previous forum entries so not all dates and users are included.

Keyboard won't work for UK English

Hi Fantastic Distro - everything works great except I cant get it to use a UK Keyboard. I have changed everything to English UK and told it to apply system wide - rebooted but still it uses a @ instead of " and other keys don't work either. Advise greatly accepted. Zeb...


  • There are several things that you need to know and that I need to know before I can truly help you. Assuming that you are installing the distro to a hard drive - you need to select the correct keyboard during the full installation routine. Selecting the proper language after the installation has completed will require you to select your choice of language from the login screen. (Where you give Peach OSI your password). At the top right there is a pull down menu where you can select your choice of English.

    If you are trying to run in live mode from a DVD or USB drive without persistence, I would boot into Peach OSI and then run the Setup Languages menu item from the Applications icon at the top of the page, once booted into Peach OSI. Although English is the default language you may need to let the system update the English database from the Language Setup routine for running Live. (Please note - if you are live booting without persistence your settings will not be saved from boot to boot.

    If you are booting Peach OSI into a virtual environment you also can select your keyboard during the installation process. And last but not least - I know that you don't need a distro of Peach OSI with more than the English language but you might try downloading one of the multiple language distros of Peach OSI - denoted with the "L" in the download. The language pack distros have already had all the included languages updated and that might help your issue. You could remove whatever language packs you didn't need after completing the installation.
  • Thanks for replying so quickly This is installed to a hard disk and yes I did choose UK Language at install and yes I have installed the UK English language and picked the English Language at login - none of that worked. It would appear there is a known bug with i-bus which means you have to run i-bus setup and on the "input method" tab choose "customise active input methods". In there was the English - English (UK, extended WinKeys) the one I chose at install. I removed American English from within there. Exited and all is working OK now.

    Happy Days Zeb
  • Glad you worked it out. I will see what I can do, if anything, as for making this i-bus change in the next scheduled update. Thanks for your due diligence in resolving this issue yourself..
Sign In or Register to comment.

Peach OSI\\\\\\\'s Forum

| A Free Operating System Alternative
@ 2017 Peach, All rights reserved.
Designed and Powered by Peach OSI

Contact us
(email us for phone number)

Get In Touch